Symantec System Recovery (SSR) console fails to launch with COM error 80040154

Article:TECH213032  |  Created: 2013-12-04  |  Updated: 2013-12-15  |  Article URL http://www.symantec.com/docs/TECH213032
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution


Subject

Issue



After installing third-party products affecting .NET Framework configuration, the Symantec System Recovery (SSR) console (VProConsole.exe) fails to launch with the following error:


Error



An unknown error has occurred during this operation.
Retrieving the COM class factory for component with CLSID {69C3E4B8-ACC2-41F0-85D6-403C53A9A38D}
Failed due to the following error: 80040154 class not registered.


Cause



VProConsole.exe is a 32-bit application but is built on the .NET Framework using the "AnyCpu" configuration, which implies that .NET by default expects it to be a 64-bit app when running on a 64-bit version of Windows.


Solution



Reconfigure the .NET Framework as follows:

1) Open regedit.exe and go to the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework.
3) Check for a DWORD value called Enable64Bit.  If it does not exist, create it.
4) Set the value of Enable64Bit to 1.
5) Reboot.
6) Try launching the SSR console.

Symantec Corporation has acknowledged that the above-mentioned issue is present in earlier versions listed under the Product(s) Section of this article. Symantec Corporation is committed to product quality and satisfied customers.
 
There are no plans to address this issue by way of a patch or hotfix in earlier versions of the software at the present time.  However, the issue has been addressed in the revision of the product specified at the end of this article. 
 
Please contact your Symantec Sales representative or the Symantec Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.  For information on how to contact Symantec Sales, please see  http://www.symantec.com
 


Supplemental Materials

SourceETrack
Value3324941


Article URL http://www.symantec.com/docs/TECH213032


Terms of use for this information are found in Legal Notices