Symantec Management Agent takes 100% processing time of a CPU

Article:TECH215206  |  Created: 2014-02-20  |  Updated: 2014-07-07  |  Article URL http://www.symantec.com/docs/TECH215206
Article Type
Technical Solution


Issue



Symantec Management Agent takes 100% processing time of a CPU.

Another symptom specfic to this issue is if the taskamangement folder is deleted and the agent restarted the problem goes away for a period of time.


Environment



7.1 sp2 mp1 v4


Cause



This is caused by the agent attempting to process a large ammount of task history and is unable to complete the process.


Solution



This issue is fixed in a future release (post 7.1 sp2 mp1 v9).  On the client machines customers will be able to add a registry setting to clear old task entries by date or by number of entries.

 

The following Dword values will configure this option on the agent

 

Two new configuration values created.
HKLM\Software\Altiris\Altiris Agent\Plugin Objects\Agents\ClientTaskAgent\TaskHistoryMaxEntries

and

HKLM\Software\Altiris\Altiris Agent\Plugin Objects\Agents\ClientTaskAgent\TaskHistoryMaxAge

Configuring these registry values will allow agents to keep up and not take over one of the CPUs on a machine.

The registry keys listed above can now be used on endpoints running point fix version 10.  Point fix version 10 can be found at the following location:  www.symantec.com/docs/HOWTO81832  v10 includes an updated agent version of:  7.1.15480.8480.




Article URL http://www.symantec.com/docs/TECH215206


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