NetBackup vCenter plugin is showing a blank screen

Article:TECH217321  |  Created: 2014-05-07  |  Updated: 2014-05-19  |  Article URL http://www.symantec.com/docs/TECH217321
Article Type
Technical Solution



Issue



After installating and configuring NetBackup Plugin for vCenter, the plugin screen is blank.  They are no errors reported just a blank white screen where the plugin should be seen.


Cause



The issue is caused when using underscores "_" in the host name of the vCenter plugin.  Internet Explorer does not play well with hostnames with underscores in the name.

A valid hostname cannot contain an underscore ("_") . Valid hostnames can contain only alphabets [A-Z], digits [0-9] and hyphen [-]. 

Please refer to RFCs:
RFC1912 (http://www.ietf.org/rfc/rfc1912.txt)
RFC952 (http://www.ietf.org/rfc/rfc952.txt)
RFC1123 (http://www.ietf.org/rfc/rfc1123.txt)

Per Hostname guidelines (http://en.wikipedia.org/wiki/Hostname):

"While a hostname may not contain other characters, such as the underscore character (_), other DNS names may contain the underscore. Systems such as DomainKeys and service records use the underscore as a means to assure that their special character is not confused with hostnames. For example, _http._sctp.www.example.com specifies a service pointer for an SCTP capable webserver host (www) in the domain example.com. Note that some applications (e.g. Microsoft Internet Explorer) won't work correctly if any part of the hostname contains an underscore character."

More information about Internet Explorer eating cookies when hostname include underscore can be found at:
http://blog.smartbear.com/software-quality/internet-explorer-eats-cookies-with-underscores-in-the-hostname/

This issue may also occur when using domain names with two characters.
http://support.microsoft.com/kb/310676

 


Solution



Rebuild the NetBackup Plugin for vCenter using a hostname that does not include an underscore "_" character and the hostname must be longer than two characters.


Supplemental Materials

SourceETrack
Value3474769
Description

vCenter plugin shows a blank screen.



Article URL http://www.symantec.com/docs/TECH217321


Terms of use for this information are found in Legal Notices