KNOWN ISSUE: Upgrade: off-box upgrade scenario does not work as SMP 7.1.SP2 MP1.1 Rollup v9 agent cannot be re-targeted to an 7.5 NS

Article:TECH223111  |  Created: 2014-07-21  |  Updated: 2014-07-28  |  Article URL http://www.symantec.com/docs/TECH223111
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Article Type
Technical Solution


Issue



 Offbox upgrade scenario from SMP 7.1.SP2 to SMP 7.5:

1. Install ITMS 7.1.SP2  MP 1.1 and latest roll-up (v9 in my case).
2. Rollout SMA and ITMS plugins to all clients
3. Install ITMS 7.5 to different server
4. On 7.1.SP2 NS open NS Console -> All Settings -> Agent plugins -> SMA -> Targeted Settings. Switch to "Advanced" tab of SMA settings and specify 7.5 NS Name and Web.
5. Go to client and update configuration.

Expected: client switch to the 7.5 NS and works with it. 
Actual: client will not switch to the new NS. In SMA log error "Invalid response from server" will occur.


Environment



 Problem reproducible with SMA 7.1.SP2 MP1.1 Rollup v9 and not reproducible with SMP from original 7.1.SP2 (no MP, no rollups).


Cause



 Known issue. Changes made in “Altiris.web.NS dll”.  Version of NS Server is added to error response of GetClientPolicies.aspx.

 


Solution



This issue has been addressed in the ITMS 7.5 SP1 release.

A pointfix is available for customers that have not upgraded to ITMS 7.5 SP1 (for those that are still in ITMS 7.5 HF6). See attached "Pointfix_eTrack3495896_7.5_HF6.zip"

VERSION  REQUIREMENT: 

SMP 7.5 with HF6 installed (See DOC7337)

 

HOW TO INSTALL THIS POINTFIX:

  1. Extract files from the archive to the NS hard drive. Make sure Point Fix is not extracted to Altiris install directory (or any subfolder to it).
  2. Execute PFInstaller.exe with administrative privileges (right-click > Run as administrator). Select "Install Files".
  3. Accept UAC (User Account Control) if prompted, select Install Files. Old binaries will be automatically backuped to the Backup folder at the same location where PFinstaller is and replaced with the new ones. Log-file Log.txt will be created at the same location where PFinstaller is.
  4. Close PFInstaller window.

 

HOW TO UNINSTALL THIS POINTFIX:

  1. Make sure that Backup subfolder is located in PFinstaller directory
  2. Execute PFInstaller.exe with administrative privileges (right-click > Run as administrator). Old binaries will be repaired from Backup folder located at the same location where PFinstaller is. NS services should be started automatically.
  3. Accept UAC (User Account Control) prompt, select Uninstall Files.
  4. Close PFInstaller window.

 

CHANGES MADE:

1. Changes made in “Altiris.web.NS dll”.
     Version of NS Server is added to error response of GetClientPolicies.aspx.

 

This hotfix has the following known issues:

None


Attachments

Pointfix_eTrack3495896_7.5_HF6.zip (270 kBytes)

Supplemental Materials

SourceETrack
Value3495896


Article URL http://www.symantec.com/docs/TECH223111


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