KNOWN ISSUE: Axengine.exe creates a second service when executed manually

Article:TECH40273  |  Created: 2008-07-01  |  Updated: 2013-05-30  |  Article URL http://www.symantec.com/docs/TECH40273
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution

Product(s)

Issue



I recieve an error upon booting the server stating that a service failed to start. The error listed in the Windows* System event log is:

The Altiris Deployment Server service failed to start due to the following error: The service did not start due to a logon failure.

The Altiris Deployment Server service failed to start due to the following error: The service did not start due to a logon failure.

Upon checking the Services control panel, I see an Altiris Deployment Server service that is set to start automatically and has not yet started.

When I attempt to start this service, an error dialog is displayed:

Error 1069: The service did not start due to a logon failure.

Could not start the Deployment Server service on Local Computer. Error 1069: The service did not start due to a logon failure.

Upon closer inspection of this service, it is noted that the Log On As credentials contain ".\" instead of the application identity account selected during installation. When the correct application identity credentials are specified and an attempt is made to start the service, I now receive the following:

Error 1053: The service did not respond to the start or control request in a timely fashion.

 

Could not start the Altiris Deployment Server service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion.

Environment



Deployment Solution 6.9 all versions
 


Cause



The Axengine.exe has been executed manually and has installed as a service.  Executing the axengine.exe file manually (after an installation or ugrade of Deployment Solution 6.9) will prompt you to install the Altiris Deployment Server service:

Altiris Deployment Server Install as a service? 

Install as a service?

When Yes is clicked this warning dialog is displayed:

An unsupported operation was attempted

An unsupported operation was attempted.

The service installation then completes and you will now have two Deployment Server services attempting to start at the same time:

 Altiris Deployment Server INstallation Complete

Installation Complete

The evidence of when this occurred will show as a Windows Event Log Application Popup Event 26:

Application popup: Altiris Deployment Server : Install as a service?

 

Application popup: Altiris Deployment Server: Install as a service?

Solution



Disable or delete the additional service that has been created by the axengine.exe. This service will not contain your application identity credentials and has not been created as part of the original installation.

To delete the service from a command line, run the following:

SC delete "Altiris Deployment Server"

Note: If preferred, you can disable the service via the services properties dialog.

 

Your services list on a Deployment Server (including PXE) should correctly list the followng:

Altiris eXpress Server

 


Supplemental Materials

ValueLB 69900
Description

Logged in Littlebuggy (Altiris - Lindon, Plymouth) database


Legacy ID



42893


Article URL http://www.symantec.com/docs/TECH40273


Terms of use for this information are found in Legal Notices