Exchange 2007 backups to tape using the Granular Recovery Technology (GRT) option fail with the MAPI CDO error even though MAPI CDO package is installed on the Exchange server.

Article:TECH57472  |  Created: 2008-01-08  |  Updated: 2013-10-23  |  Article URL http://www.symantec.com/docs/TECH57472
Article Type
Technical Solution


Issue



Exchange 2007 backups to tape using the Granular Recovery Technology (GRT) option fail with the MAPI CDO error even though MAPI CDO package is installed on the Exchange server.

 


Error



Final error: 0xe0001207 - To support individual mailbox message and folder restores from Information Store backups, you must download and install the Microsoft Exchange Server MAPI Client and Collaboration Data Objects package version 06.05.7888 or later on the Exchange 2007 server.

Exchange 2007 GRT backups to tape fail with the above error even though the MAPI CDO package has been installed on the Exchange 2007 server. Same backup job when targeted to a backup to disk folder completes successfully with exceptions. But the restore from the backup to disk backup set fails with MAPI CDO error.

 


Cause



The above error can occur if the registry on the Exchange 2007 server has been modified to redirect the "ProgramFilesDir" and "ProgramFilesDir (x86) to an alternate location other than the default. For example:

X:\APPS and X:\APPS (x86) respectively.

The registry values are located under the path HKLM | Software | Microsoft | Windows | CurrentVersion in the registry.

When Backup Exec or the Remote Agent for Windows Servers (RAWS) is installed on the server the 32-bit files for the application get copied and registered in the C:\Program Files (x86)\Symantec\Backup Exec path. Backup Exec does not follow the path specified in the registry. However when the backup job is run it looks for the 32-bit files in the path specified in the registry and since the files are not present there it causes the job to fail.

 


Solution



To fix the above error follow the steps mentioned below:

1. On the Exchange 2007 server copy the C:\Program Files (x86)\Symantec directory to the path specified in the registry (path specified in the "ProgramFilesDir (x86)" value in the registry). For example X:\APPS (x86).

2. Open a command prompt window and change directories to point to X:\APPS (x86)\Symantec\Backup Exec directory.

3. Run the following commands:

     regsvr32 RemsrvPS32.dll
     Remsrv.exe /regserver

4. Rerun the backup job.

Note: Henceforth if the "remsrv.exe" and "remsrvps32.dll" files get replaced by a hotfix, then the workaround steps mentioned above will need to be re-implemented.
 
 

Permanent Solution:
This issue has been fixed in Backup Exec 12.0. To resolve the problem upgrade to Backup Exec 12.0 or above

 


Supplemental Materials

SourceUMI
ValueV-79-57344-4615
Description

Error. Cannot backup directory and its subdirectories.


SourceError Code
Value0xe0001207
Description

To support individual mailbox message and folder restores from Information Store backups, you must download and install the Microsoft Exchange Server MAPI Client and Collaboration Data Objects package



Legacy ID



297571


Article URL http://www.symantec.com/docs/TECH57472


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