How to free up disk space on a Symantec Messaging Gateway (SMG) appliance

Article:TECH96749  |  Created: 2009-01-13  |  Updated: 2013-07-26  |  Article URL http://www.symantec.com/docs/TECH96749
Article Type
Technical Solution

Product(s)

Issue



Managing disk space on a SMG appliance.


Symptoms
You are running out of disk space on the appliance and want to know how to free up some disk space.



 


Cause



You can ultimately run out of disk space on a SMG appliance due to certain configurations and events if routine maintenance is not performed.


Solution



It is a good practice to periodically perform some maintenance tasks on the appliance to keep the disk from filling up.

Control Center role


    1. Quarantined messages:
      • Make sure to regularly delete old messages from the quarantine in Spam > Email Spam.
      • You can automate this process by going to Spam > Quarantine settings. Under the “Spam Quarantine Expunger” heading, set some thresholds and ensure that messages are expunged regularly.

    2. Compliance incidents:
      • Make sure to regularly delete old incidents from the incident folders in Content > Incident Management.
      • You can keep a record of your incidents by exporting them with the “Export Incident History” button.

    3. Reporting data:
      • You can manually delete reporting data in Administration > Reports, and click on “Delete Data Now”.
      • The Brightmail Gateway is set to expunge reporting data older than 7 days. You can adjust this to your needs.

    4. Logging database:
      • You can manually clear all scanner logs from the log database by going to Status > Logs and clicking on “Clear All Scanner Logs”
      • The Brightmail Gateway is configured to expunge the log database once logs are 7 days or older, and has a default maximum log size of 50MB. You can adjust this in Administration > Logs

    5. Database backups:
      • You can download or delete old backups in Administration > Version > Restore/Download

    6. Message Audit Logs:
      • You can backup the Message Audit Logs from each scanner to a remote server using the admin CLI command "mallog". The command supports scp/ftp to backup and scp/ftp and http to restore.
      • You can manually clear all Message Audit Logs from the scanners by using the admin CLI commands below:
    (a) On versions 8.0 and older the admin CLI command is "clear mallogs"
    (b) On versions 9.0 and later the admin CLI command is "delete mallogs"


    NOTE: Message Audit Logs are stored separate on each scanner , make sure you backup and clear the logs on each scanner on your deployment.


Scanner role

    1. Core files are useful when troubleshooting a crash, but take up a lot of space and should be deleted when not in use.
      • Log in to the command-line interface with the admin account.
      • Run “delete cores"
    2. Log files are separate from the log database on the control center.
      • Log in to the command-line interface with the admin account.
      • Run “delete scannerlogs” to remove all such logs.
      • See “help delete” for more information on clearing specific log files


All appliance types

    1. Old software update cache
      • Log in to the command line interface
      • Run “clear sudata” for version 8 or run "delete sudata" for version 9 and above.





 




Legacy ID



2009101317270554


Article URL http://www.symantec.com/docs/TECH96749


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