1. Symantec-Broadcom-Horizontal/
  2. Security Response/
  3. Attack Signatures/
  4. OS Attack: NetBIOS MS PnP QueryResConflist BO

OS Attack: NetBIOS MS PnP QueryResConflist BO

Severity: High

This attack could pose a serious security threat. You should take immediate action to stop any damage or prevent further damage from happening.

Description

This signature detects attempts to exploit a buffer overflow vulnerability in the Windows Plug and Play.

Additional Information

Microsoft Windows Plug and Play (PnP) service is used by the operating
system to detect new hardware.

The PnP service is prone to a buffer overflow vulnerability. This
vulnerability presents itself because the application does not perform
boundary checks prior to copying user-supplied data into sensitive
process buffers.

Specifically, this issue takes place when the PnP service handles
malformed messages containing excessive data. These messages are passed
to a finite sized buffer, triggering an overflow condition and
facilitating memory corruption. A successful attack may result in
arbitrary code execution, which can allow an attacker to gain SYSTEM
privileges.

This vulnerability facilitates local privilege escalation and
unauthorized remote access depending on the underlying operating system.
A remote unauthenticated attacker can exploit this issue on Windows 2000.
It is conjectured that on Windows 2000, an attacker would likely exploit
this issue using NULL session enumeration to gain access. On Windows XP
SP1 a remote attacker must authenticate over RPC to exploit this issue.
Windows XP SP2 and Windows Server 2003 require an attacker to have local
access to an affected computer for successful exploitation.

Microsoft has reported that other protocols such as Internetwork Packet
Exchange (IPX) and Sequenced Packet Exchange (SPX) may be vulnerable to
this issue as well. This has not been confirmed.

Reports indicate that this issue may lend itself to the development of
self-propagating malicious code due to the lack of user interaction and
authentication required for exploitation against Windows 2000.

** A worm exploiting this vulnerability has been reported in the wild.
Users are advised to deploy patches or implement appropriate mitigation -
such as blocking TCP port 445 at the network boundary - against the
exploitation of this vulnerability.

The various families of malware exploiting this vulnerability include;
Zotob, Esbot, Spybot, Tilebot, Bobox, Reattle, Randex and Codbot

Affected

  • Avaya IP600 Media Servers R10, R11, R12, R6, R7, R8, R9
  • Avaya S3400 Message Application Server
  • Avaya S8100 Media Servers R10, R11, R12, R6, R7, R8, R9
  • Microsoft Windows 2000 Advanced Server SP1, SP2, SP3, SP4
  • Microsoft Windows 2000 Datacenter Server SP1, SP2, SP3, SP4
  • Microsoft Windows 2000 Professional SP1, SP2, SP3, SP4
  • Microsoft Windows 2000 Resource Kit
  • Microsoft Windows 2000 Server SP1, SP2, SP3, SP4
  • Microsoft Windows 2000 Server Japanese Edition
  • Microsoft Windows 2000 Terminal Services SP1, SP2, SP3, SP4
  • Microsoft Windows 2000 Workstation rev.2031, rev.2072, rev.2195, SP1, SP2, SP3
  • Microsoft Windows 95 Build 490.R6, j, SP1, SR2
  • Microsoft Windows 98 a, b, j, SP1
  • Microsoft Windows 98 With Plus! Pack
  • Microsoft Windows 98SE
  • Microsoft Windows CE 2.0, 3.0, 4.2
  • Microsoft Windows ME
  • Microsoft Windows NT 3.5, 3.5.1, 3.5.1 SP1, 3.5.1 SP2, 3.5.1 SP3, 3.5.1 SP4, 3.5.1 SP5, 3.5.1 SP5 alpha, 4.0, 4.0 alpha, 4.0 SP1, 4.0 SP1 alpha, 4.0 SP2, 4.0 SP2 alpha, 4.0 SP3, 4.0 SP3 alpha, 4.0 SP4, 4.0 SP4 alpha, 4.0 SP5, 4.0 SP5 alpha, 4.0 SP6, 4.0 SP6 alpha, 4.0 SP6a, 4.0 SP6a alpha
  • Microsoft Windows NT 4.0 Option Pack
  • Microsoft Windows NT Enterprise Server 4.0, 4.0 SP1, 4.0 SP2, 4.0 SP3, 4.0 SP4, 4.0 SP5, 4.0 SP6, 4.0 SP6a
  • Microsoft Windows NT Server 4.0, 4.0 SP1, 4.0 SP2, 4.0 SP3, 4.0 SP4, 4.0 SP5, 4.0 SP6, 4.0 SP6a
  • Microsoft Windows NT Terminal Server 4.0, 4.0 alpha, 4.0 SP1, 4.0 SP2, 4.0 SP3, 4.0 SP4, 4.0 SP5, 4.0 SP6, 4.0 SP6a
  • Microsoft Windows NT Workstation 4.0, 4.0 SP1, 4.0 SP2, 4.0 SP3, 4.0 SP4, 4.0 SP5, 4.0 SP6, 4.0 SP6a
  • Microsoft Windows Server 2003 Datacenter Edition SP1, SP1 Beta 1
  • Microsoft Windows Server 2003 Datacenter Edition Itanium SP1, SP1 Beta 1
  • Microsoft Windows Server 2003 Datacenter x64 Edition
  • Microsoft Windows Server 2003 Enterprise Edition SP1, SP1 Beta 1
  • Microsoft Windows Server 2003 Enterprise Edition Itanium SP1, SP1 Beta 1
  • Microsoft Windows Server 2003 Enterprise x64 Edition
  • Microsoft Windows Server 2003 Standard Edition SP1, SP1 Beta 1
  • Microsoft Windows Server 2003 Standard x64 Edition
  • Microsoft Windows Server 2003 Web Edition SP1, SP1 Beta 1
  • Microsoft Windows Vista beta
  • Microsoft Windows XP
  • Microsoft Windows XP 64-bit Edition SP1
  • Microsoft Windows XP 64-bit Edition Version 2003 SP1
  • Microsoft Windows XP Embedded SP1
  • Microsoft Windows XP Home SP1, SP2
  • Microsoft Windows XP Media Center Edition SP1, SP2
  • Microsoft Windows XP Professional SP1, SP2
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Tablet PC Edition SP1, SP2

Response

Workaround
The referenced Microsoft security bulletin contains workarounds to help prevent attacks. Please see the security bulletin for more information.

Microsoft has released fixes to address this vulnerability in supported platforms.

Microsoft Upgrade Security Update for Windows 2000 (KB899588)
Microsoft Windows 2000 Advanced Server SP4
Microsoft Windows 2000 Datacenter Server SP4
Microsoft Windows 2000 Professional SP4
Microsoft Windows 2000 Server SP4

Microsoft Upgrade Security Update for Windows Server 2003 (KB899588)
Microsoft Windows Server 2003 Standard Edition
Microsoft Windows Server 2003 Enterprise Edition
Microsoft Windows Server 2003 Datacenter Edition
Microsoft Windows Server 2003 Web Edition
Microsoft Windows Server 2003 Datacenter Edition SP1
Microsoft Windows Server 2003 Enterprise Edition SP1
Microsoft Windows Server 2003 Standard Edition SP1
Microsoft Windows Server 2003 Web Edition SP1

Microsoft Upgrade Security Update for Windows Server 2003 64-bit Itanium Edition (KB899588)
Microsoft Windows Server 2003 Enterprise Edition 64-bit
Microsoft Windows Server 2003 Datacenter Edition 64-bit
Microsoft Windows Server 2003 Datacenter Edition 64-bit SP1
Microsoft Windows Server 2003 Enterprise Edition 64-bit SP1

Microsoft Upgrade Security Update for Windows Server 2003 x64 Edition (KB899588)
Microsoft Windows Server 2003 Standard x64 Edition
Microsoft Windows Server 2003 Enterprise x64 Edition
Microsoft Windows Server 2003 Datacenter x64 Edition

Microsoft Upgrade Security Update for Windows XP (KB899588)
Microsoft Windows XP Home SP1
  • Twitter
  • Facebook
  • LinkedIn
  • Google+
  • YouTube